macOs Big Sur “ 无法打开×××,因为无法验证开发者。“

今天升级了 macOs Big Sur 系统,然后就启动不了 flutter 项目了,弹出提示框 " 无法打开dart,因为无法验证开发者。"

因为 macOs Big Sur 系统在安全方面做了增强,所以我们需要 👇🏻 👇🏻 👇🏻 

方法一:

找到无法打开的程序,右键打开,此时会出现一个提示框,选择 “ 打开 ” 即可。

若还是没办法打开,则打开使用方法二。

macOs Big Sur “ 无法打开×××,因为无法验证开发者。“

方法二:

打开   系统偏好设置→安全性与隐私→通用→解锁→允许从以下位置下载App→更改为任何来源

若没有任何来源选项,执行 sudo spctl --master-disable 就会新增一个任何来源选项

macOs Big Sur “ 无法打开×××,因为无法验证开发者。“       macOs Big Sur “ 无法打开×××,因为无法验证开发者。“

温馨提示:只有软件第一次运行,需要得到允许,所以建议软件运行一次后,就把权限改回 App Store和被认可的开发者。

 

版权声明:玥玥 发表于 2021-04-16 21:57:35。
转载请注明:macOs Big Sur “ 无法打开×××,因为无法验证开发者。“ | 女黑客导航